Hazard Notice: MariaDB "InnoDB: Failing assertion" Issues
Incident Report for Digital Pacific
Resolved
As advised on the cPanel Known Issues Status Page, the bad MariaDB package has been removed from the repository. See https://forums.cpanel.net/threads/known-issues-status-page.644133/post-2710361

MariaDB have not yet published the fixed package, but the broken package should no longer be installed by a WHM update.

There will be no further updates to this status page - please continue to monitor the MariaDB release page if you are waiting on the newest package to become available: https://mariadb.com/kb/en/library/mariadb-10320-release-notes/
Posted Nov 08, 2019 - 13:42 AEDT
Monitoring
MariaDB have advised that a fix has been released, however there are currently no official packages available for it. You can find a link to the release notes below:
https://mariadb.com/kb/en/library/mariadb-10320-release-notes/

For any Self-Managed clients still experiencing issues, please review the MariaDB Jira task which provides workarounds/solutions to this issue: https://jira.mariadb.org/browse/MDEV-20987

Once an official package has been released for download, we will provide another status update.
Posted Nov 07, 2019 - 10:53 AEDT
Identified
There has been an upstream issue regarding MariaDB failing to start with InnoDB Failed Assertion errors.
cPanel has identified this as an issue with MariaDB (Case ID MDEV-20987).
This issue is affecting the following MariaDB versions:

10.1.42
10.2.28
10.3.19
10.4.9

We are taking proactive action in an attempt to mitigate the impact of this MariaDB update.

cPanel is working with MariaDB on a fix as a priority. As soon as a fix is released, we will deploy it to our Managed VPS and Dedicated server fleets.

Updates will be provided as they become available.
Posted Nov 06, 2019 - 10:57 AEDT
This incident affected: Dedicated Servers and VPS Hosting.