Digital Pacific website
Incident Report for Digital Pacific
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 16:04 AEDT
Identified
We are currently investigating issues with our website digitalpacific.com.au.
This has not affected our client area billing.digitalpacific.com.au, so customers can still access their accounts as normal.
Posted Dec 12, 2019 - 15:47 AEDT
This incident affected: Digital Pacific Website.