Website Interruption - digitalpacific.com.au
Incident Report for Digital Pacific
Resolved
This incident has been resolved.
Posted 5 months ago. May 08, 2019 - 14:26 AEST
Investigating
Be advised our monitoring has indicated that there is currently an issue accessing our primary company website (www.digitalpacific.com.au).

If you are trying to access the Client Area (our billing, contact and security PIN management system) you can head to https://billing.digitalpacific.com.au/

We are working to resolve this with top priority and will provide an update in 60 minutes, or if there is a significant change in the situation.
Posted 5 months ago. May 08, 2019 - 14:22 AEST
This incident affected: Digital Pacific Website.