Fire drill underway at Sydney office
Incident Report for Digital Pacific
Resolved
This incident has been resolved.
Posted May 18, 2021 - 11:18 AEST
Investigating
Please be aware that there is a fire drill currently underway at our Sydney office. While this is underway, there will be delays to ticket responses and Phone support.
Posted May 18, 2021 - 11:06 AEST
This incident affected: Technical Support (Tickets) and Technical Support (Phone).