The issue affecting email delivery to certain external recipients has now been resolved.
Our investigation determined that the issue was related to the SpamExperts email filtering service. As part of the remediation process, the API version was updated, which restored normal email delivery operations.
Our Team will continue to closely monitor the environment to ensure ongoing stability.
We appreciate your patience and understanding while we worked to address this issue.
Posted Jun 15, 2026 - 13:22 AEST
Identified
We are aware of an issue currently affecting email delivery to certain external providers, including Gmail and Hotmail domains.
Our Engineering Team is actively investigating the issue and working around the clock to restore normal email delivery as quickly as possible.
Please be assured that resolving this issue is our highest priority. We will continue to provide timely updates as soon as additional information becomes available.
We appreciate your patience and understanding while we work toward a resolution
Posted Jun 15, 2026 - 08:38 AEST
This incident affects: Personal and Business Hosting and Reseller Hosting.