Phone-Support Temporarily Unavailable
Incident Report for Digital Pacific
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 12:09 AEDT
Update
Staff have returned to the building and phone support is available.
Posted Nov 05, 2019 - 12:05 AEDT
Monitoring
Due to a fire evacuation, our phone support is currently unavailable.

Please login to your Client Account to submit a support request if necessary.

https://billing.digitalpacific.com.au/
Posted Nov 05, 2019 - 10:00 AEDT
This incident affected: Technical Support (Tickets) and Technical Support (Phone).